ArcEngine的axTOCControl按住shift实现选中多个图层

gisweis 回复了问题 • 3 人关注 • 2 个回复 • 45 次浏览 • 2019-12-10 17:20 • 来自相关话题

参考了之前的一些解决办法使用了ITOCControlDefault.SelectItem,现在主要问题是ITOCControlDefault.SelectItem每一次使用会自动清除上次选择,无法完成多选

无法将类型为“System.__ComObject”的对象强制转换为类型“ESRI.ArcGIS.DataSour

anguanxing 回复了问题 • 3 人关注 • 2 个回复 • 27 次浏览 • 2019-12-05 10:12 • 来自相关话题

在打开gdb数据库的时候报错,报错的行是:FileGDBWorkspaceFactory gdbwf = new FileGDBWorkspaceFactory();
就这一行报出了无法将类型为“System.__ComObject”的对象强制转换为类型“ESRI.ArcGIS.DataSour的错

engine,在编辑节点状态下,删除节点后,使图形变化

sasa 回复了问题 • 3 人关注 • 1 个回复 • 84 次浏览 • 2019-12-03 16:34 • 来自相关话题

使用engine编辑一个面图层,在更改要素的编辑任务下编辑面节点,使用IEngineSkechOperation进行删除节点的操作,当对该操作调用Finish方法后,面的边线发生了变化,但是面的填充没有变化。如果对feature.shpae赋值后调用store方法,图形可以变化,但是退出了节点编辑状态(边线有绿色小方块)。应该如何在编辑操作之后,对编辑后的图形进行更新显示并且不退出节点编辑状态呢?

利用arcengien 进行ExtractValuesToPoints 出现 ERROR 010092: 无效的输出范围。

朱新颖 回复了问题 • 3 人关注 • 2 个回复 • 71 次浏览 • 2019-12-02 16:06 • 来自相关话题

大家有遇到过吗,有什么解决建议吗?

请问如何根据图层获得所在组图层?

朱新颖 回复了问题 • 2 人关注 • 1 个回复 • 38 次浏览 • 2019-12-02 09:24 • 来自相关话题

请问ArcEngine 里如何移除整个组图层,包括这个组一起移除?

回复

xyy 回复了问题 • 1 人关注 • 1 个回复 • 38 次浏览 • 2019-11-30 09:44 • 来自相关话题

如何将谷歌地图的UTM坐标系统转换为其他的坐标系统

瓶子_694 回复了问题 • 2 人关注 • 1 个回复 • 76 次浏览 • 2019-11-28 18:31 • 来自相关话题

谷歌地图的UTM坐标是wgs84 下的坐标系统转换为其他的坐标系统 怎么实现 感谢大佬

arcengine 10.6 开发环境部署

liangxiongwei 回复了问题 • 4 人关注 • 5 个回复 • 1175 次浏览 • 2019-11-26 12:12 • 来自相关话题

arcengine 10.6 ,vs2017 开发环境部署,无法启动调试,sdk 已经安装,但项目无法启动。还需要什么配置。sdk不需要授权吧,原来用的是10.2

arcengine中如何正确释放gp工具?

朱新颖 回复了问题 • 2 人关注 • 1 个回复 • 66 次浏览 • 2019-11-22 11:59 • 来自相关话题

本人利用GP工具实现融合,必须释放gp工具,尝试利用如下方式:$(document).ready(function() {$('pre code').each(function(i, block) { hljs.highlightBlock( block); }); });System.Runtime.InteropServices.Marshal.FinalReleaseComObject(

GP工具产生的"尝试读取或写入受保护的内存。这通常指示其他内存已损坏"

朱新颖 回复了问题 • 3 人关注 • 3 个回复 • 81 次浏览 • 2019-11-22 11:49 • 来自相关话题

使用GP工具,出现了"尝试读取或写入受保护的内存。这通常指示其他内存已损坏 ";请问有没有什么好的办法解决

topology.addclass增加一个要素类后,第二次运行在添加就报错了。是什么原因?

koococo 回复了问题 • 2 人关注 • 1 个回复 • 525 次浏览 • 2019-11-20 13:09 • 来自相关话题

c# ae10.1二次开发,拓扑检查的时候运行topology.AddCalss,增加一个要素类,没有添加过得要素类运行没问题,但是第二次运行再添加的时候就报错,难道是一个要素类只能添加一次吗?还是其他的原因?急求助!

arcengine中图例该怎样做可以实现分组?

回复

haker 发起了问题 • 1 人关注 • 0 个回复 • 61 次浏览 • 2019-11-16 10:24 • 来自相关话题

在arcengine中的pagelayoutcontrol即布局视图中,已经添加好了图例,添加方式代码如下 #region 添加图例
case 2:
pLegend2 = new LegendClass_2();
pElement = axPageLayoutCo