使用arcgis js无法保存新增要素

许丹石 回复了问题 • 2 人关注 • 1 个回复 • 114 次浏览 • 2019-06-24 11:50 • 来自相关话题

要编辑通过sde发布的featurelayer,一个是使用Tomcat服务器可以保存成功,另一个是使用IIS服务器就无法保存成功,另外测试的graphic是包含attributes和symbol等信息的,但是在IIS上要是去掉其他的只保留geometry,且geometry中只含有"type":"point"和x,y坐标是可以保存成功,多其他的就不行,不知道

zoom 无效

许丹石 回复了问题 • 2 人关注 • 1 个回复 • 106 次浏览 • 2019-06-24 11:45 • 来自相关话题

我用的是3.2版本
esriBasemaps.delorme = {
            baseMapLayers: [{
                url: baseMapURL
            }],
            title: "Delorme"
        };
map = new Map("mapDiv", {
 

ArcGIS API for JavaScript中如何用WebTiledLayer加载百度地图实时路况服务作为一个图层添加到地图中?

许丹石 回复了问题 • 2 人关注 • 1 个回复 • 113 次浏览 • 2019-06-24 11:38 • 来自相关话题

JS API 4.4中如何应用Echart插件

润润家的糖果波 回复了问题 • 6 人关注 • 5 个回复 • 1302 次浏览 • 2019-06-21 18:51 • 来自相关话题

小弟小白一枚,要使用4.4 API 实现popupTemplate弹窗显示Echart统计图,在graphic的popupTemplate.content中定义了一个div,但是无法获取到div的对象,没有办法加载。请各位大神指点迷津。

刚部署好的arcgis api4.3,测试时出现左上角的放大缩小样式出现问题?

小2222k 回复了问题 • 4 人关注 • 2 个回复 • 1354 次浏览 • 2019-06-20 19:53 • 来自相关话题

放大缩小样式有问题,放大缩小的功能可以用,





将main.css替换成在线的样式,就恢复正常了,请问怎么解决?
 

ENOTFOUND Package dijit-themes not found?

回复

gaob 发起了问题 • 1 人关注 • 0 个回复 • 98 次浏览 • 2019-06-20 15:48 • 来自相关话题

我试着使用bower管理arcgis api for js。当我使用bower install --save arcgis-js-api初始时总是报ENOTFOUND Package dijit-themes not found这个错误,请问如何解决?

arcgis api for js 没有直接的 api 做迁移图??需要EchartsLayer??

atlas1563 回复了问题 • 2 人关注 • 1 个回复 • 87 次浏览 • 2019-06-20 11:11 • 来自相关话题

popupTemplate弹窗的大小怎么控制

atlas1563 回复了问题 • 2 人关注 • 1 个回复 • 93 次浏览 • 2019-06-20 10:38 • 来自相关话题

我在API中没有找到控制弹窗大小的地方,弹窗内容如果过多会是以一个下滑动的效果显示,虽然停靠的效果是可以的  但是需要手动点击一下  体验和视觉很差。

arcgis for js 4.0能不能添加自定义的canvas图层?

DeanW 回复了问题 • 5 人关注 • 3 个回复 • 1374 次浏览 • 2019-06-19 20:31 • 来自相关话题

比如我有这样的一个场景,我首先需要在canvas上渲染一些动画,然后再将canvas添加到arcgis地图中,使得地图在缩放、拖拽时,canvas也能跟随动态变化。类似图中这种迁徙。

arcgis api 4.x对IE等各个浏览器的支撑问题

李阳 回复了问题 • 2 人关注 • 1 个回复 • 111 次浏览 • 2019-06-17 09:06 • 来自相关话题

arcgis api for js 4.x(4.8)加载自定义的切片地图出错???

回复

beants 发起了问题 • 1 人关注 • 0 个回复 • 156 次浏览 • 2019-06-11 20:42 • 来自相关话题

我使用的arcgis api 是4.8的版本,使用的切片是由arcgis server10.2.2发布的,结果切片图就加载不出来,发布的动态图可以加载出来,控制台提示是无法解析,10.2.2的server不支持。其中arcgis api中view不管使用SceneView三维视图还是MapView二维视图都无法加载,
请问这是怎么回事呢,如果三维场景中要加载切片地图,该用到哪些类呢?
谢谢!!!

arcgis api for JavaScript4.10字体文件提示跨域

dhy 回复了问题 • 4 人关注 • 3 个回复 • 614 次浏览 • 2019-06-11 14:50 • 来自相关话题

我在调用arcgis api for javaScript时,控制台总是会提示9个字体文件跨域的问题,但是我对应的跨域访问已经开启。想请教一下这个问题该怎么解决