arcgis版本兼容性

我想了解一下arcgis的各个版本兼容性的问题(mdb数据库及mxd)。
1、arcgis10.2中的文件arcgis10.1是否通用?  
2、argis10.22 与arcgis10.2是否通用?
3、arcgis10.2对在arcgis9.3中创建的数据库修改之后,arcgis9.3还能否使用?数据库的结构等是否有改变?
已邀请:

turtle

赞同来自: 江宝骅 徐珂 x_hola

我了解的情况是,
1. shapefile文件肯定都是通用;
2. 地理数据库文件则会有版本兼容性问题,高版本可打开低版本创建修改过的地理数据库,低版本则不能打开高版本创建修改过的地理数据库;针对该问题,可以考虑在高版本创建地理数据时指定可兼容的版本号;

江宝骅

赞同来自: 徐珂 turtle x_hola

MXD
1、10.2和10.1通用。如下图
360截图20161216184928669.jpg

2、10.22和10.1也通用

地理小子 - Love GIS! Love Life!

赞同来自: x_hola

你好,对于你的三个问题:
1、10.1和10.2的数据库文件(mdb, gdb), 地图文档文件(mxd)是直接可以互相兼容通用的。
2、ArcGIS10.2.2和10.2属于二级子版本,各类文件肯定都是通用的。
3、ArcGIS9.3和10.0,对于数据库,9.3的可以北10.x打开,也可以用过【升级地理数据库】工具升级到当前高版本。被当前高版本编辑过的数据库,也可以通过【创建地理数据库】选择创建9.x的版本数据库,然后将编辑过的要素类导入,然后在9.x中使用。至于mxd文档。类似于word的doc和docx。只能向下兼容。

扫地和尚

赞同来自:

在使用arcgis初始,特别是9.3和10.0的兼容问题,都是高版本支持低版本。

要回复问题请先登录注册