Error:  Packaging succeeded, but publishing failed. ERROR 001369: Failed to create the service

相关信息
Article ID: 40391
Software:
ArcGIS for Server 10.1
Platforms:
Linux-SUSE Server 11
RHEL 5, 6

错误信息
If the data referenced by a GIS resource resides in a Samba directory, the following error displays in ArcGIS for Desktop when publishing:

"Packaging succeeded, but publishing failed. ERROR 001369: Failed to create the service."

Any subsequent attempts to publish result in the same error.

错误原因
This failure results from opportunistic locking, or oplocks, which is a Windows file-locking feature. When oplocks are enabled in a Samba directory, the Windows machine is allowed to cache files locally. Usually, this is the machine that is being used to publish the service. If a second machine needs access to the data, it must receive an oplocks break from the Windows machine before the file is synchronized back to the second machine. Usually, this is the machine that the service is being published to. If a break is received by the Windows machine during publishing, the subsequent data synchronization may cause publishing to fail.
已邀请:

EsriSupport

赞同来自:

解决方案
Disable oplocks for each Samba directory. To do so, follow these steps:
  1. On the machine hosting Samba, open smb.conf.
  2. For each directory configured to be accessible through Samba, add the following properties:
    [folder]      ...      oplocks = false      level2 oplocks = false      ...
  3. Save smb.conf.
  4. Run the command 'testparm' to verify that the properties appear in the Samba configuration file.
  5. Restart Samba (SMB) and NetBIOS (NMB) services.


创建及修改时间
Created: 6/22/2012

Last Modified: 10/1/2012
原文链接
http://support.esri.com/en/kno ... 40391

fengwei

赞同来自:

解决方案或解决方法

禁用每个 Samba 目录的 oplock。 为此,请执行以下步骤:

在托管 Samba 的计算机上,打开 smb.conf。
对于配置为通过 Samba 访问的每个目录,添加以下属性: 

[folder] ... oplocks = false level2 oplocks = false ...
保存 smb.conf。
运行“testparm”命令,验证 Samba 配置文件中是否存在这些属性。
重新启动 Samba (SMB) 和 NetBIOS (NMB) 服务。

要回复问题请先登录注册