postgresql版sde(10.4.1)安装说明

2
分享 2018-05-15
从ArcGIS 10.3开始,彻底没有了sde的安装包,安装sde数据库需要先安装arcgis desktop,通过arccatalog建数据库,同时也不能建sde服务,只能使用直连

以下演示在sde 10.4.1版在pg数据库中首次添加sde数据库操作

sde10.4.1版支持的pg版本最高是9.4,因此此例使用的pg版本为9.4.17 64位版,关于postgres 9.4.17 64位版安装说明请看本博客相关文章

建库前有些前置操作,在ArcGIS desktop的安装目录中,找到pg 9.4 64位版的dll文件


复制到pg安装目录下的lib文件夹下





PS:网上有些文章还说因为arcgis desktop是32位而pg是64位还要另外复制一些dll文件,但我没遇到,大家小心



然后开始首次建sde库,打开arccatalog,再打开arctoolbox,找到如下工具(创建企业数据库)



录入如下

红框1:数据库类型,选pg

红框2:instance(实例):填的是pg服务端的ip。PS:如果pg端口不是默认的5432,那还要填端口,具体格式请看说明

红框3:数据库名称,第一个sde数据库名称叫sde,后面再有其他项目使用的sde库可以按项目命名

红框4:pg管理员用户(默认是postgres)的用户名和密码

红框5:sde数据库的sde用户的密码。PS:新建sde库时会自动新建名称为sde的用户

红框6:许可文件(ecp文件),请向有关人士获取



最后完成建库
 
postgresql 9.4.17 64位安装说明:http://zhihu.esrichina.com.cn/article/3741
postgresql版sde(10.4.1)安装说明:http://zhihu.esrichina.com.cn/article/3743
postgresql版sde(10.4.1)新建数据库:http://zhihu.esrichina.com.cn/article/3742
ArcGIS Desktop新建postgresql版sde(10.4.1)的连接:http://zhihu.esrichina.com.cn/article/3740

0 个评论

要回复文章请先登录注册